Forum Clubic

Beryl + Ubuntu 6.10 + 3D - AIE

Bonsoir

J’ai un “assez gros” problème avec les jeux et beryl. Il arrive que quand je quitte neverball ou armagetron, X plante complètement. Le clavier ne fonctionne même plus on dirai, seule la souris fonctionne.

Alors j’ai suivi ce petit tuto : http://doc.ubuntu-fr.org/applications/xgl/…s_avec_les_jeux
Mais hélas sa ne change rien… :pt1cable:

J’ai pas bien compris ce qui se passe, mais :

Serait-il possible de lancer le jeux sur ctrl + alt + F9 par exemple ?
En cas de plantage, serait-il possible que le processus se tue tout seul ? ou avec un raccouric clavier ?

xgl ?? xgl n’est plus utile de nos jours que pour les cartes ati récentes (non reconnes par le driver libre radeon) et les cartes nvidia anciennes (non reconnues par le driver proprio)
Comme dans ton dernier post, tu avais une carte nvidia récente, je suppose que tu n’as toujours pas réussi à faire fonctionner le driver nvidia 9xxx.
Une nouvelle version est sortie récemment (sensée être stable)

  • l’as-tu tentée ?
  • si elle ne marche pas, as-tu envoyé un rapport de bogue à nvidia ?
  • si elle marche, pourquoi utilises-tu xgl ?

Même dans ce cas là, la version de développement de beryl inclue un mode Non-TFP qui commence a marcher pas trop mal (contrairement a ce que j’ai dit sur un autre forum) avec la build de ce matin.

Quand je parle d’XGL, je parle de beryl. XGL c’est le serveur graphique non ?
Si j’ai réussi à faire fonctionner le driver nvidia 9xxx.

Le problème, c’est que quand je quitte un jeu en plein écran, sa arrive assez souvent que sa me plante totalement X, ctrl + alt + retour ne fonctionne même plus.

il me semble que c’est normal que ça plante avec les jeux…

N’y a t-il pas moyen de lancer une sorte de second serveur graphique sans nuire aux performances ? :??:

si il me semble que c’est marqué sur le site de ubuntu dans la partie documentation beryl vers la fin

Sur le forum Gentoo y’a un topic sur le script xlaunch http://forums.gentoo.org/viewtopic-t-483004.html

Par contre si tu utilise encore XGL tu devrais essayer de t’en passer, j’utilise nvidia pour faire tourner Beryl et aucun plantage dans les jeux !

il parle bien de beryl

moi pour lancer un nouveau X pour jouer, j’utilise ce petit script :

#!/bin/bash

echo "exec '/usr/bin/xterm -geometry 800x600+0+0'" > /tmp/.my_xinitrc
XINITRC=/tmp/.my_xinitrc

xinit -- /usr/bin/X :1 -layout GameLayout &>/dev/null &

En sachant que l’option -geometry 800x600+0+0 ne marche pas et je ne sais pas pourquoi, j’ai toujorus un terminal (xterm) en 640x480 :riva:

je sais, il y a une faille de sécurité, me faites pas chier :na: en effet, si votre umask n’est pas à 00x, en particulier, si quelqu’un arrive à écrire dans votre fichier /tmp/.my_xinitrc après sa création mais avant le lancement de X, il exécutera ce qu’il veut avec vos droits !

Comme par défaut, X ne peut-être lancer que par root, la faille mentionné au dessus peut s’averer plus dangereuse que prévu :ane:

l’otion “-layout GameLayout” est bien évidement optionnelle, ici GameLayout est un serveur layout que j’ai configuré dans mon xorg.conf en plus du “défault layout” avec quelques options qui m’arrangent pour les jeux, en particulier une profondeur par défaut à 16 bits.

vous pouvez remplacer le xterm par autre chose, j’ai fait une super servece menu pour KDE en lançant mplayer avec un server layout qui active ma sortie télé, c’est super pratique ça se lance en cliquant droit sur les fichiers de type vidéo dans konqueror :wink: