Forum Clubic

Beryl et sa barre superieure

bonjour
je viens d’installer beryl mais un souci se pose pour moi
la barre superieure des applications avec les boutons fermer agrandire reduire
n’apparait pas.
j’ai eu beau fouiller impossible de la faire apparaitre meme avec des themes la
proposant
qesaco?
je me debrouille avec les raccourcis clavier du coup mais bon…
merci d’avance,

je suis sous kde (mandriva 2007)
j’ai déja tenté de rechearger ça ne change rien
j’ai placé des raccourcis beryl dans le dossier autostart pour qu’il se lance au démarrage

"des" raccourcis ? beryl-manager suffit, il gère tout ça.
Maisq regarde dans beryl-settings si le plugin decoration est chargé et si emerald est lancé

je suis nouveau sous linux cependant
-beryl manager ne se lance pas au démarrage d’ou mon placement dans autostart
decoration est coché et emerald est lancé (theme rezlook-graphite; moteur trueglass)
mon xorg.conf donne ça:

File generated by XFdrake (rev 57713)

Section "Device"
Identifier "device1"
VendorName "nVidia Corp."
BoardName "NVIDIA GeForce FX (generic)"
Driver "nvidia"
Option "DPMS"
Option "RenderAccel" "True"
Option "DisableGLXRootClipping" "True"
Option "Backstoring" "True"
EndSection

nvidia-xconfig: X configuration file generated by nvidia-xconfig

nvidia-xconfig: version 1.0 (buildmeister@builder3) Wed Nov 1 19:47:17 PST 2006

File generated by XFdrake (rev 57713)

**********************************************************************

Refer to the xorg.conf man page for details about the format of

this file.

**********************************************************************

Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
InputDevice "SynapticsMouse1" "AlwaysCore"
Screen "screen1" 0 0
EndSection

Section "Files"
# font server independent of the X server to render fonts.
# minimal fonts to allow X to run without xfs
FontPath "unix/:-1"
FontPath "/usr/share/fonts/misc:unscaled"
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "/usr/lib/xorg/modules/extensions/libglx.so"
Load "glx" # 3D layer
EndSection

Section "ServerFlags"
#DontZap # disable <Crtl><Alt><BS> (server abort)

# allows the server to start up even if the mouse does not work
#DontZoom # disable &lt;Crtl&gt;&lt;Alt&gt;&lt;KP_+&gt;/&lt;KP_-&gt; (resolution switching)
Option &quot;allowmouseopenfail&quot;

EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "fr"
Option "XkbOptions" "compose:rwin"
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/mouse"
EndSection

Section "InputDevice"
Identifier "SynapticsMouse1"
Driver "synaptics"
Option "SHMConfig" "on"
EndSection

Section "Monitor"
# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
Identifier "monitor1"
HorizSync 31.5 - 90.0
VertRefresh 60.0 - 60.0
ModeLine "768x576" 50.0 768 832 846 1000 576 590 595 630
ModeLine "768x576" 63.1 768 800 960 1024 576 578 590 616
ModeLine "1152x768_120" 156.4 1152 1240 1368 1584 768 769 772 823 -hsync +vsync
ModeLine "1152x768_100" 127.6 1152 1232 1360 1568 768 769 772 814 -hsync +vsync
ModeLine "1152x768_85" 106.5 1152 1224 1352 1552 768 769 772 807 -hsync +vsync
ModeLine "1152x768_75" 92.4 1152 1224 1344 1536 768 769 772 802 -hsync +vsync
ModeLine "1152x768_60" 71.7 1152 1208 1328 1504 768 769 772 795 -hsync +vsync
ModeLine "1152x768_50" 58.9 1152 1200 1320 1488 768 769 772 791 -hsync +vsync
ModeLine "720x480_120" 59.3 720 760 840 960 480 481 484 515 -hsync +vsync
ModeLine "720x480_100" 48.0 720 760 832 944 480 481 484 509 -hsync +vsync
ModeLine "720x480_85" 39.8 720 752 824 928 480 481 484 505 -hsync +vsync
ModeLine "720x480_75" 34.9 720 752 824 928 480 481 484 502 -hsync +vsync
ModeLine "720x480_60" 26.7 720 736 808 896 480 481 484 497 -hsync +vsync
ModeLine "720x480_50" 21.8 720 728 800 880 480 481 484 495 -hsync +vsync
ModeLine "360x240_120" 14.1 360 368 408 456 240 241 244 258 -hsync +vsync
ModeLine "360x240_100" 11.2 360 368 400 440 240 241 244 255 -hsync +vsync
ModeLine "360x240_85" 9.1 360 360 392 424 240 241 244 253 -hsync +vsync
ModeLine "360x240_75" 8.0 360 360 392 424 240 241 244 251 -hsync +vsync
ModeLine "360x240_60" 5.9 360 344 376 392 240 241 244 249 -hsync +vsync
ModeLine "360x240_50" 4.7 360 336 368 376 240 241 244 248 -hsync +vsync
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultDepth 24

Subsection &quot;Display&quot;
    Depth 8
    Modes &quot;1152x768&quot; &quot;720x480&quot; &quot;360x240&quot;
EndSubsection

Subsection &quot;Display&quot;
    Depth 15
    Modes &quot;1152x768&quot; &quot;720x480&quot; &quot;360x240&quot;
EndSubsection

Subsection &quot;Display&quot;
    Depth 16
    Modes &quot;1152x768&quot; &quot;720x480&quot; &quot;360x240&quot;
EndSubsection

Subsection &quot;Display&quot;
    Depth 24
    Modes &quot;1152x768&quot; &quot;720x480&quot; &quot;360x240&quot;
EndSubsection
Option &quot;DPMS&quot;

EndSection

Section "Extensions"
Option "Composite" "Enable"
Option "RENDER" "Enable"
EndSection
voila, voila…
merci pour votre aide

je vais essayer, cependant je n’ai pas de repertoire nvidia
est ce que je dois le créer puis mettre le fichier libglx.so que j’ai dedans?
ou est ce un glx spécial?

en fait tux racer marche c’est supertux qui ne marche pas (plateforme 2D)
en effet c’est le repertoire /usr/lib/xorg/modules/extension/nvidia
qui n’existe pas et libglx.so est dans /usr/lib/xorg/modules/extensions
j’ai installé à partir du driver .run que j’ai pris sur le site nvidia.

bon je viens d’ajouter Option “AddARGBGLXVisuals” “True” dans la section concernée,
il n’y a pas de changement concernant la barre, ni concernant tux
en fait l’écran que j’obtiens en lançant tux intervient avant le logo et à vue d’oeil (il dure 1/2 seconde) il affiche le type de kernel et la machine i686

bug dans l’interface chaise - clavier je pense (chez moi beryl-manager suffit)

j’ai dit une connerie; je viens de redemarrer l’ordi et ça y est la barre sup
est apparue. je pensais que relancer une session suffisait c donc la ligne:
Option “AddARGBGLXVisuals” “True”
qui causait mes problèmes
merci et merci encore (ptigars t’es solide, tu réponds souvent a mes pbs, t’es cool :wink: ) merci à tous