Forum Clubic

Avoir définitivement le controle total (droits administrateurs)

Bonjour à tous,

j’essaye en vain depuis hier d’installer Company of heroes “opposing fronts”, sur mon PC équipé de W7 64 bits.
Au début de l’installation, ce message apparait:
http://img6.imageshack.us/img6/5852/sanstitreuip.th.jpg

Uploaded with ImageShack.us

Je précise un détail. Juste avant le message d’erreur, “C++” apparait sur les fichiers en cours de traitement.

Je soupçonne plusieurs choses:

  • Les droits administrateurs qui me bloquent
  • l’histoire du C++, qui me fait penser à Redistributable. (comment savoir si ma version est à jour ?)
  • Windows Installer qui fait des sienne, bien que ne sachant pas ce que c’est !

C’est un problème qui m’agace particulièrement car je sais pas quoi faire du tout, et que je suis complètement bloqué.
Je sollicite votre aide,

Merci d’avance.

www.clubic.com…

Bonjour.

Auparavant , créer manuellement un point de restauration des fichiers systèmes . Cliquer sur Démarrer\Exécuter
Taper control sysdm.cpl,3 , cliquer sur l’onglet Protection du système , activer le disque système puis en bas
cliquer sur Créer , donner un nom quelconque au fichier de sauvegarde , ceci est une sécurité pour restaurer le
système en cas de problèmes .

Copier/coller le texte ci-dessous juste entre les pointillés dans Bloc-Notes (ou autres éditeurs de texte),
l’enregistrer sous le nom de fix.reg sur le bureau , ensuite cliquer dessus et accepter la fusion dans le registre ,
et enfin le supprimer.

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT*\shell\runas]
@=“Se rendre Propriétaire”

[HKEY_CLASSES_ROOT*\shell\runas\command]
@=“cmd.exe /c takeown /f “%1” && icacls “%1” /grant administrators:F”

[HKEY_CLASSES_ROOT\Directory\shell\runas]
@=“Se rendre Propriétaire”

[HKEY_CLASSES_ROOT\Directory\shell\runas\command]
@=“cmd.exe /c takeown /f “%1” /r /d y && icacls “%1” /grant administrators:F /t”

Ainsi en faisant un clic droit sur un un dossier ou fichier , vous aurez l’option

Se rendre Propriétaire. . Mais parfois , il est nécessaire de le faire en mode sans échec.
Edité le 23/12/2010 à 22:13

:hello:

  1. Normalement, Windows doit accorder les droits admin à l’installeur, au pire fait un clic droit dessus et choisis “Executer en tant qu’administrateur”.

  2. Dans ce cas le redistribuable C++ doit être mis à jour par l’installeur, je n’ai jamais vu de cas où c’était un facteur bloquant à l’install.

  3. A voir si tu as le problème avec d’autres installeurs utilisant Windows Installer. :jap:

La fenêtre d’erreur me dit qu’il y a eu un problème lors de l’installation du paquet Windows Installer.

C’est quoi ce truc svp ?

Je commence à fumer de la tête là, j’vais bientôt passer à la console môa … :@:@

ps: le jeu s’installe correctement sur un autre ordi qui a win XP.
ps2: d’autres jeux comme Bioshock 2 ou dead space s’installent sans souci.
Edité le 24/12/2010 à 17:13

Solution extrême : Tu tentes de recopier le dossier du jeu installé sous XP vers ton PC avec Windows 7.

J’ai eu quelques soucis moi aussi de jeu qui voulait pas s’installer parceque le dossier “Mes Documents” n’était pas valide. Solution : Formatage, j’ai jamais réussi à résoudre ce problème.

Tu as essayer de mettre à jour le package MSI ?

Non j’ai pas essayé, je savais même pas qu’on pouvait.
Je vais chercher comment faire ça déjà.


Bon je trouve pas comment faire proprement. J'ai bien trouvé une version 4.5 mais rien me dit qu'elle est compatible w7 ... J'ose pas l'installer. Edité le 24/12/2010 à 17:32