Forum Clubic

Autorun

J’ai besoin d’un petit coup de main pour un Autorun.

J’ai crée un autorun qui ouvre une page html lors de l’insertion du CD.

Sur cette même page html, il y a un lien qui doit ouvrir une seconde page html.
Sous IE 6 et même IE 7. Le problème vient de Firefox que se soit la version 1.5.0.7 ou 2.0 RC3.

Donc mon problème c’est que Firefox n’ouvre pas le lien présent sur la première page HTML.

Donc voilà, il y a donc deux solutions possibles, soit on trouve l’astuce pour réaliser cette action possible sous Firefox soit il faut forcer l’ouverture de cette page dans IE.

J’attends donc votre aide.

Merci d’avance.

heu… le problème il est où ?

La page ne se lance pas ?
Le lien ne fonctionne pas ? (dans ce cas pourquoi ne pas ouvrir directement la deuxième page ? )

Modification faite ^^

Le problème n’est donc pas l’autorun mais le html, non ?

donne nous le code

J’ai l’impression que le bloc :
<!-- attention ici commande fond sonore pour IE–>
<bgsound src=“accueil/music/in-this-world.mp3” loop="-1">
<!-- attention ici fin de la commande fond sonore pour IE–>

est mal placé, il ne fait partie ni du <head>, ni du <body>, un peu moche de mettre ça là. :neutre:

Et pourquoi dans ta page, après le </BODY>, tu as encore des balises head et body tout à la fin ? :heink:

C’est fait avec DreamWeaver

Mais c’est pas ça mon problème elle marche la pag comme ça c juste Firefox qui comprend pas que la page suivane et sur le CD…

Bonour,
oui, bon, même sir le problème ne vient pas de là, c’est plus simple de debugger du code propre :smiley:
supprime ça


<head>
<title>Cousinade - Bienvenue</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
</head>

<body>
</body>

Ensuit, c’est ton lien relatif qui ne foncitonne pas, alors il y a plusieurs pistes possibles:

  1. la casse: Bienvenue.html (perso j’évite les majuscules dans les urls) vérifie que le fichier a bien cette casse sur le CD
  2. que se passe il quand tu clique sur le lien (une 404): quelle est l’adresse qui s’affiche alors dans la barre d’adresse? regarde les différences par rapport à une url qui fonctionnerait sous Firefox.

autre possibilité: il est possible que ça fonctionne, mais que dans le cache de firefox, il ai gardé l’url avec justement une mauvaise casse => vide bien le cache et l’historique avant tes essais.

pour résoudre ces paorblèmes: peut-être un “base href” dans le head si c’est un pbm de lien relatif.
:slight_smile:

Bah enfait firefox ne comprends pas que le fichier suivant se trouve sur le CD, il le cherche sur le disque local et donc il me sort page non trouvée.

Et je ne peux pas mettre une lettre par défaut car cette dernière varie en fonction des ordis…

Oui, mais as-tu vérifié ce que je t’ai dit: la casse, et l’url que le browser tente d’ourvir?
:slight_smile:

C’est bon ça marche.

J’ai effectuer des modifications. j’avais mis un / devant le nom du lien.

^^

++
Merci

Ok, c’est cool si ça marche :super:

merci de ta réponse :slight_smile: