Forum Clubic

Audigy 2 value sous Mandrake 10.1

Bonjour tout le monde,

J’ai voulu retenter l’aventure linux hier soir. J’ai choisi Mandrake 10.1 car cela m’arrangeait (pas besoin de la télécharger), et en plus le système me semblait assez simple pour débuter.

Pour l’instant tout fonctionne bien, sauf une chose : la carte son. Comme je débute, je sais pas trop quoi faire… Sous KDE j’ai un peu fouillé dans les paramètres sonores, mais rien trouvé de bien folichon. Sur le net, quelques débuts de piste, mais ça ne m’a pas vraiment aidé.

Le chip audio de la carte mére est en principe désactivé.
A64 3200+, 1Go DDR400, Asus K8N-E Deluxe, Mandrake 10.1 DVD

Donc voilà, comment faire fonctionner cette carte ? :ange:

Merci d’avance. :jap:

Ça doit sûrement fonctionner si tu prends emu10k (le pilote de l’Audigy2, il me semble) via le centre de contrôle Mandriva (partie matérielle).

Enfin, en tout cas, j’étais passé sans souci d’un chipset intégré à ma Terratec de cette façon ;).

Merci… Mais pourrais-tu détailler un petit peu la procédure ou à la limite me dénicher un tutorial (que je n’ai pas trouvé) ?

Parce qu’en fait là Harddrake 2 me trouve une carte son sur le port PCI n°2 (ce qui est juste si l’on commence à compter d’en bas), mais il ne reconnaît pas le fabricant, ni le modèle, etc… et il affiche Pilote : Module : inconnu.
Et si je lance “l’outil de configuration”, il me dit “Aucune carte son détectée !”
Donc je ne sais pas trop par où commencer…

Merci mille fois. :jap:

En fait, le pilote est emu10k1, ensute la page suivante peut aider http://www.mandrake.tips.4.free.fr/sysspec.html , notamment le /etc/modprobe.conf (alias sound-slot-0 snd-emu10k1), ensuite, ça doit fonctionner via le centre de contrôle Mandriva (je te dis cela dès que je suis sous Mandriva).

Merci.

Si j’ai bien compris, je dois modifier mon fichier modeprob.conf en y rajoutant la ligne “alias sound-slot-0 snd-emu10k1” ? Après cela, je pourrai configurer correctement ma carte son ?

Ah au fait, pour modifier ce fichier, je dois apparemment me connecter en root… Comment je fais ? Parce que si je fais “Démarrer une session”, je n’ai que ma propre session dans ma liste…

Hmm, c’est pas simple tout ça avec des années de Windows dans les pattes, mais j’suis motivé là, je m’accroche…

Merci à nouveau. :jap:

normalement, tu n’as pas à faire cela, avant toute chose, ne touche pas à ce fichier, et donne :
1/ ton /etc/modprobe.conf
2/ lsmod | grep snd
3/ regarde avec urpmf sur tu as des infos sur d’éventuels paquets contenant emuk10k1 (et s’ils sont installés).

Centre de contrôle Mandriva -> onglet Matériel (à gauche) -> vérifier et configurer votre matériel.

Ensuite, il va checker ton matos (éventuellement te proposer des mises à jour), et là, tu peux aller dans la partie Carte son et configurer le module (configuration du module, lancer l’outil de configuration, à faire en premier).

[fixed][root@jcpLinux jcp]# urpmf --name emu10k1
emu10k1-tools:emu10k1-tools-0.9.4-4mdk.i586.rpm
[root@jcpLinux jcp]# urpmf --provides emu10k1
emu10k1-tools:emu10k1-tools[== 0.9.4-4mdk]
[root@jcpLinux jcp]# urpmf --description emu10k1
as10k1:This is an assembler for the emu10k1 DSP chip present in the
creative SB live, PCI 512, and emu APS sound cards. It is used to
make audio effects such as a flanger, chorus or reverb.
emu10k1-tools:The emu-tools work with the emu10k1 driver include in the kernel.[/fixed]
ok, emu10k1-tools semble être un bon candidat pour utiliser ta carte de façon sympathique.

Enfin, avant tout cela, il faut bien configurer Alsa pour te servir de ta carte son (cf ma remarque du post précéd).

Accessoirement, fait attention au volume qui est souvent à zéro au début!

Aussi :wink: (sauf qu’une fois, en testant le cvs, il était à fond, ça réveille :D).

Kmix pour le mixeur (sous KDE).

1/ Mon fichier modeprob.conf :
[cpp]# This file is autogenerated from /etc/modules.conf using generate-modprobe.conf command

alias eth0 forcedeth
alias eth2 sundance
alias eth3 eth1394
install scsi_hostadapter /sbin/modprobe sata_nv; /sbin/modprobe sata_sil; /bin/true
install usb-interface /sbin/modprobe ohci-hcd; /sbin/modprobe ehci-hcd; /bin/true
alias eth1 via-rhine
alias ieee1394-controller ohci1394[/cpp]

2/ lsmod | grep snd
je dois faire quoi avec ça ?

3/ Si je tape “urpmf emu10k1” il me donne une liste impressionnante de touts les fichiers qui s’appellent comme ça… Je ne sais pas trop quoi en faire, mais ça doit vouloir que le ou les paquets nécessaires sont installés.

4/ Centre de contrôle Mandriva -> onglet Matériel (à gauche) -> vérifier et configurer votre matériel.
Je ne trouve pas “vérifier et configurer votre matériel.” Ca a un autre nom sous Mandrake 10.1 ?

5/ Le volume à zéro
Dès que j’essaie de démarrer KMix, il plante lamentablement… Y a-t-il un autre moyen de vérifier le volume ?

Je rame… Je rame…

Merci mille pour pour ta patience. :jap::jap:

lsmod | grep snd -> taper la commande et donner le résultat sur le topic.

Exemple, chez moi :
[fixed][13:33][jcp@phoenix]
[~] > lsmod | grep snd
snd_ice1724 49316 1
snd_ice17xx_ak4xxx 3008 1 snd_ice1724
snd_ac97_codec 67872 1 snd_ice1724
snd_pcm 81352 2 snd_ice1724,snd_ac97_codec
snd_timer 20868 1 snd_pcm
snd_page_alloc 7428 1 snd_pcm
snd_ak4xxx_adda 5184 2 snd_ice1724,snd_ice17xx_ak4xxx
snd_mpu401_uart 6016 1 snd_ice1724
snd_rawmidi 19936 1 snd_mpu401_uart
snd_seq_device 6988 1 snd_rawmidi
snd 45540 10 snd_ice1724,snd_ac97_codec,snd_pcm,snd_timer,snd_ak4xxx_adda,snd_mpu401_uart,snd_rawmidi,snd_seq_device
soundcore 7328 1 snd[/fixed]

4/ j’ai donné le cheminement pour une Mandriva LE2005 (mais, sur la version précéd, je ne sais plus là :p, mais ça doit se trouver facilement).

Pour ton modeprob.conf, ok, tu n’as donc aucun module son de configuré, forcément, pas de son.

Ririfi88:
D’après les infos que tu nous as donné, le pilote de la carte n’est pas configuré, donc forcément le mixer a du mal :stuck_out_tongue:

sur la 10.0
Configurez votre ordi-> matériel-> matériel-> selectionne ta carte dans la lsite des composants (il n’y a pas marqué ‘son’ à côté?)

1/ lsmod | grep snd -> taper la commande et donner le résultat sur le topic.
Oui j’ai essayé, il me dit “bash: lsmod: command not found”, donc je pensais m’être trompé…

2/ j’ai donné le cheminement pour une Mandriva LE2005 (mais, sur la version précéd, je ne sais plus là :p, mais ça doit se trouver facilement).
Oui, j’ai quand même cherché, mais tout ce que je peux faire c’est configurer les périphériques/modules déjà installés… Je ne vois rien qui ressemble à “vérifier et configurer votre matériel”.

Pas grave… Je continue…

Merci encore (mais tu commences à avoir l’habitude)

Oui d’accord, mais si je vais dans le “Centre de contrôle Mandrake”, puis dans “Matériel”, puis si je sélectionne la carte son et je clique sur “Lancer l’outil de configuration”, Mandrake me dit “Aucune carte son n’a été détectée sur votre ordinateur. Blablabla…” Et là, je peux que faire “Ok” et je tourne en rond, je ne peux pas allez plus loin.

Snif…

Et si tu fais ça :
modprobe emu10k1

Tu as du son?

Alors là il me répond “bash: modprobe: command not found”
Hem… Je suppose que ce n’est pas le genre de réponse que tu attendais… :sarcastic:

NB : faut lancer les commandes modprobe, lsmod en root ;).

Donc:
#su -
motdepasse
puis
modprobe emu10k1

Voilà, j’ai tapé cette commande, mais ça n’a pas réglé le problème…

Voilà le résultat d’un lsmod | grep snd, maintenant que je sais le faire :slight_smile: :
[cpp]snd-usb-audio 61312 0
snd-pcm 81800 1 snd-usb-audio
snd-timer 20356 1 snd-pcm
snd-page-alloc 7400 1 snd-pcm
snd-usb-lib 11136 1 snd-usb-audio
snd-rawmidi 19300 1 snd-usb-lib
snd-seq-device 6344 1 snd-rawmidi
snd 45988 5 snd-usb-audio,snd-pcm,snd-timer,snd-rawmidi,snd-seq-device
soundcore 7008 1 snd
usbcore 103172 10 snd-usb-audio,snd-usb-lib,ati_remote,pwc,usbhid,usblp,ehci-hcd,ohci-hcd[/cpp]

Je comprends pas vraiment pourquoi il parle d’USB… Y aurait-il un conflit avec ma webcam usb Logitech (micro intégré) ?