Forum Clubic

Aucun son - ni système, ni mp3, ni vidéo

salut,
je n’arrive pas à avoir du son sur ma Suse 10.0 OSS-GM
ce depuis l’install (récente)
j’ai essayé le tuto son de Néolinux, http://wiki.alionet.org/doku.php?id=avoir_du_son_sous_suse
rien à faire , je n’ai rien ni au casque, ni autrement

dans Kmix je n’arrive pas à faire ca manip : je n’ai que l’onglet ‘output’ :frowning:

voici ma carte son :
http://img107.imageshack.us/img107/996/capture125mm.th.jpg

Sauriez vous que faire ?

Tu as bien configurer alsa?
J’ia une carte son sensiblement identique sur mon portable et sous ubuntu comme sur fedora, aucun problème de son.

N’hesite pas aussi a tester un livecd pour voir si tu as du son. Si oui, essaie de voir ce qu’il y a de différent avec ton installation de suse (utilisation d’alsa,…).

Edit: je viens de regarder le tuto comme tu l’appelles et on ne peut pas dire qu’il soit très détaillé :paf: , mais c’est sur que c’est pas forcément tres long a expliquer. Dans K ⇒ Centre de configuration de KDE ⇒ Son et multimédia ⇒ Système de sons, si alsa ne marche pas mets-en un autre, mais normalement c’est celui qu’il faut utiliser.

A tout hasard, monte le volume dans kmix :wink:

ben je t’avoue que je ne connais Rien à Linux encore, donc la config d’Alsa je l’ai pas faite, c’est resté par défaut.
tu peut m’expliquer?
là je viens d’avoir une mise à jour d’Alsa via Yast, qui sait :wink:

essais d’installer alsamixergui, lance le et “dé-mute” tout ce que tu peux dedans.
j’ai eu un soucis une fois avec kmix qui n’arrivais pas à démuter le son principal (même si la petite diode s’allumait bien)
Je l’ai fait une fois avec alsaixergui et après plus de problèmes même avec kmix :slight_smile:

flute j’ai pris alsamixergui par Yast
puis exécuter la commande : alsamixergui me dit :

alsamixer : function snd_mixer_load failed : invalid argument

*le volume est bien sûr à 100% , et muet décoché dans kmix

alors dans le gestionnaire de son j’ai mis alsa, rien, remis sur détection automatique et ca m’a planté :

http://img128.imageshack.us/img128/1682/sonko7ts.th.jpg

(no debugging symbols found)
Using host libthread_db library "/lib/tls/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 1082376288 (LWP 14772)]
[KCrash handler]
#15 0x400b2ae6 in Arts::PlayObject_base::create ()
from /opt/kde3/lib/libkmedia2_idl.so.1
#16 0x08057776 in ?? ()
#17 0xbff37e2c in ?? ()
#18 0xbff37e18 in ?? ()
#19 0x080f7b9c in ?? ()
#20 0x00000001 in ?? ()
#21 0x0000006f in ?? ()
#22 0x00000000 in ?? ()
#23 0x01f37e1b in ?? ()
#24 0x00000000 in ?? ()
#25 0xbff37e1b in ?? ()
#26 0x00000028 in ?? ()
#27 0x080f7b90 in ?? ()
#28 0x080f3320 in ?? ()
#29 0x080ef998 in ?? ()
#30 0x080f46d4 in ?? ()
#31 0x080e6094 in ?? ()
#32 0x080f470c in ?? ()
#33 0x080ef7d4 in ?? ()
#34 0x080f4cfc in ?? ()
#35 0x080e6094 in ?? ()
#36 0x080e6094 in ?? ()
#37 0x080f7b9c in ?? ()
#38 0x080f41bc in ?? ()
#39 0x00000028 in ?? ()
#40 0x00000028 in ?? ()
#41 0x408378a0 in mp
() from /lib/tls/libc.so.6
#42 0x080f2ed8 in ?? ()
#43 0xbff37e68 in ?? ()
#44 0x406e0cd0 in ?? () from /usr/lib/libstdc++.so.6
#45 0xbff37ec4 in ?? ()
#46 0x00000028 in ?? ()
#47 0xbff37e88 in ?? ()
#48 0x40699e77 in std::string::assign () from /usr/lib/libstdc++.so.6
#49 0x08053772 in ?? ()
#50 0xbff37e8c in ?? ()
#51 0x080979a8 in ?? ()
#52 0xbff37ec4 in ?? ()
#53 0x403c38a9 in Arts::Buffer::readString () from /opt/kde3/lib/libmcop.so.1
#54 0x40068681 in Arts::ByteSoundReceiver::_Creator ()
from /opt/kde3/lib/libsoundserver_idl.so.1
#55 0x403de876 in Arts::Object_skel::_dispatch ()
from /opt/kde3/lib/libmcop.so.1
#56 0x403def0e in Arts::Dispatcher::handle () from /opt/kde3/lib/libmcop.so.1
#57 0x403dfcf9 in Arts::Connection::receive () from /opt/kde3/lib/libmcop.so.1
#58 0x403dfecb in Arts::Connection::receive () from /opt/kde3/lib/libmcop.so.1
#59 0x403c542b in Arts::StdIOManager::processOneEvent ()
from /opt/kde3/lib/libmcop.so.1
#60 0x403bdab1 in Arts::StdIOManager::run () from /opt/kde3/lib/libmcop.so.1
#61 0x403bd937 in Arts::Dispatcher::run () from /opt/kde3/lib/libmcop.so.1
#62 0x08059c94 in ?? ()
#63 0xbff3a368 in ?? ()
#64 0x00000005 in ?? ()
#65 0x00000000 in ?? ()
#66 0x00000000 in ?? ()
#67 0xbff3a3ec in ?? ()
#68 0x40007fd7 in _dl_lookup_symbol_x () from /lib/ld-linux.so.2
#69 0x4072fea0 in __libc_start_main () from /lib/tls/libc.so.6
#70 0x080520d1 in ?? ()

Moi je suis sous gnome et pas kde, mais j’ai pas arts, essaie de le desactiver ou sinon desinstalle le pour voir (fait attention quand meme aux dependances).

re,
au fait, j’ai testé avec Alsa ou en ‘détection automatique’ sur lecture mp3 pas moye n d’entendre quo i que se soit…

c’est quoi arts?
t u as parlé d’alsa non?

apparement tu as un problème sérieux.

je pense que ta carte son n’est pas reconnue et le driver n’est pas chargé.

Si tu as une carte son integré et une autre en pci, pense à bien désactiver la carte integré dans le bios.

essaie aussi de poster le résultat de la commande lsmod

pourtant avec Suse 9.3 ca marchait normalement, sur le même pc je vois pas pourquoi ca bugguerait à présent (?)

Ben ça devrait marcher également.

Je vois que tu utilises KDE, est ce qu’en utilisant gnome ça fait pareil ?
Est ce que tu as des messages relatifs à ALSA ou au son dans le fichier

/var/log/messages

salut,
gnome j’arrive pas à le mettre, faut prendre GDM par Yast?

pour var/log/msg je vas aller voir (suis sur Xp)

sinon j’ia fait ca :
d’abord dans centee de config kde/systeme de son/matériel : j’ai mis Alsa, puis appliqué
(c’était sur détection automatique)

ensuite j’ai fait alsaconf en root, ca à l’air de se dérouler normalement,
j’ai pris cette carte son en haut :
http://img112.imageshack.us/img112/3703/cartesson6hq.th.jpg

puis j’ai validé et ca se fini bien, mais je n’entend pas le fichier de son donné en test. (ca demandait de fermer les appli son, j’ia fermé kmix, j’ai pt ê mal fait ?)

ensuite voici le résultat pour les commandes :


linux:/home/fabrice # hwinfo --sound
11: PCI 1b.0: 0403 Multimedia controller
  [Created at pci.277]
  UDI: /org/freedesktop/Hal/devices/pci_8086_2668
  Unique ID: u1Nb.BrgLAc8YrN3
  SysFS ID: /devices/pci0000:00/0000:00:1b.0
  SysFS BusID: 0000:00:1b.0
  Hardware Class: sound
  Model: "Fujitsu Siemens 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x2668 "82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller"
  SubVendor: pci 0x1734 "Fujitsu Siemens Computer GmbH"
  SubDevice: pci 0x1066
  Revision: 0x03
  Driver: "HDA Intel"
  Memory Range: 0xf0000000-0xf0003fff (rw,non-prefetchable)
  IRQ: 169 (1920 events)
  Module Alias: "pci:v00008086d00002668sv00001734sd00001066bc04sc03i00"
  Driver Info #0:
	Driver Status: snd_hda_intel is active
	Driver Activation Cmd: "modprobe snd_hda_intel"
  Config Status: cfg=yes, avail=yes, need=no, active=unknown

*************

linux:/home/fabrice # lsmod | grep snd
snd_seq_dummy     7812  0
snd_pcm_oss  	67616  0
snd_seq    62864  1 snd_seq_dummy
snd_seq_device   13068  2 snd_seq_dummy,snd_seq
snd_mixer_oss    24704  2 snd_pcm_oss
snd_hda_intel    23296  1
snd_hda_codec    97664  1 snd_hda_intel
snd_pcm      109700  3 snd_pcm_oss,snd_hda_intel,snd_hda_codec
snd_timer     31108  2 snd_seq,snd_pcm
snd    	71300  9 snd_seq_dummy,snd_pcm_oss,snd_seq,snd_seq_device,snd_mixer_oss,snd_hda_intel,snd_hda_codec,snd_pcm,snd_timer
soundcore     13920  3 saa7134,snd
snd_page_alloc   15112  2 snd_hda_intel,snd_pcm


*********

linux:/home/fabrice # chkconfig | grep alsa
alsasound     on

enfin pour le message dont tu parlait au départ et sa récup de alsa rc1… j’ai pas tout compris à ce qu’il fait
mais en effet c’est bien la même carte que moi.

finalement : pas de changement constaté : arrivée sur Suse 10.0 sans son, centre config kde/…/système de son/général/ tester le son buggue comme dit plus haut , mp3 ko
vous avez pas un mp3 qui marche que je vois ca? le mien j’ne suis pas trop sur.

flute j’ai ca aussi :


linux:/home/fabrice # modprobe snd-card-intel8x0
FATAL: Module snd_card_intel8x0 not found. 

c’est quoi ce truc? yast détecte ma carte pourtant

Chez moi quand je fais lsmod, j’ai entre autre :

snd_intel8x0m          19333  2
snd_intel8x0           34177  2
snd_ac97_codec         74937  2 snd_intel8x0m,snd_intel8x0
snd_pcm_oss            50673  0
snd_mixer_oss          17729  3 snd_pcm_oss
snd_pcm                98889  4 snd_intel8x0m,snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_timer              32837  1 snd_pcm
snd                    57285  11 snd_intel8x0m,snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore              10785  3 snd
snd_page_alloc          9669  3 snd_intel8x0m,snd_intel8x0,snd_pcm

Essaie alors de faire:

modprobe snd_card_intel8x0

euh tu veux dire en user de base?
je viens de faire ca en root non?

slt voilà j’ai un probleme j’ai knoppix linux live dvd v4.0.2. quand je le lance il me fais sa ptite analyse linux et au moment ou il rentre sur e systeme d’exploitation l’écran me met imput signal mais j’ai du son. il y a pas communication entre le systeme et le moniteur. je pense que linux ne détecte pas ma carte graphique et mon moniteur avec.
tu peux m’aider ste plé??
merci

Si t’es sur un portable pense a mettre l’option vga=771 au moment du lancement de knoppix (f2,f3,… pour plus d’options).
Sinon donne nous un peu plus de details sur ta config, mais fait peut etre un nouveua topic, car je ne vois pas le rapport avec celui-ci.

As-tu vérifié quand même en console, en lançant : alsamixer que tes volumes sont bien montés, et non muet (Touche M pour activer). ensuite, tu peux lancer /etc/init.d/alsamixer save

tu peux aussi, en passant faire un modules-update.

Voila.

@+

Salux,

j’ai réussi à régler le souci mais par contre un boot sous XP annule tout et je me retrouve sans son de nouveau :frowning:
Kmix : 1 seul onglet , au lieu de Output+Input+Switches
Pas de canaux volume dans Yast/matos/son/autres/volume
alsamixer : load failed
etc…

mon chipset : Realtek AL C880
et la doc alsa donne ca , mais je sais pas quoi en tirer , Help please! :clap: :clap: :sol:
/usr/src/linux-2.6.13-15.8/Documentation/sound/alsa/ALSA-Configuration.txt :

Module snd-hda-intel

Module for Intel HD Audio (ICH6, ICH6M, ICH7), ATI SB450,
VIA VT8251/VT8237A

model - force the model name
position_fix - Fix DMA pointer (0 = FIFO size, 1 = none, 2 = POSBUF)

Module supports up to 8 cards.

Each codec may have a model table for different configurations.
If your machine isn’t listed there, the default (usually minimal)
configuration is set up. You can pass “model=<name>” option to
specify a certain model in such a case. There are different
models depending on the codec chip.

Model name Description


ALC880
3stack 3-jack in back and a headphone out
3stack-digout 3-jack in back, a HP out and a SPDIF out
5stack 5-jack in back, 2-jack in front
5stack-digout 5-jack in back, 2-jack in front, a SPDIF out
6stack 6-jack in back, 2-jack in front
6stack-digout 6-jack with a SPDIF out
w810 3-jack
z71v 3-jack (HP shared SPDIF)
asus 3-jack
uniwill 3-jack
F1734 2-jack
test for testing/debugging purpose, almost all controls can be
adjusted. Appearing only when compiled with
$CONFIG_SND_DEBUG=y

Configure tes niveaux etc dans alsamixer, et ensuite /etc/init.d/alsasound save.

modules-update pour la forme… :stuck_out_tongue:

Et dis moi ce que ca donne.essaie de verifier que alsa se lance bien au boot aussi…

(sous Gentoo : rc-update status)