Forum Clubic

Asus P5E3 Deluxe : Problème de boot avec RAID 0

Bonjour à tous,

Voilà j’ai un gros problème. Je possède 2 disques Seagate 7200.11 500Go en RAID 0, et un Hitachi 250Go en SATA classique sur le même contrôleur.
Je possède une carte mère Asus P5E3 Deluxe avec contrôleur SATA Intel.
J’ai une installation de Vista sur le RAID et sur le 250Go.

Pour booter sur mon 250Go je dois faire ceci :

  • régler le contrôleur SATA dans le BIOS sur “IDE”
  • faire F8 au boot pour avoir la sélection du périphérique : je choisis bien le 250Go
  • on me propose deux installations de Vista : je choisis la 2ème, qui est celle du 250Go
  • le PC démarre normalement sur le Vista du 250Go
  • je n’ai évidemment pas accès à mon RAID dans l’explorateur… (un disque trouvé mais non accessible)

Pour booter sur le RAID (et là c’est du grand n’importe quoi et j’ai besoin d’aide !!!) :

  • je règle le contrôleur SATA dans le BIOS sur “RAID”
  • je fais F8 au boot pour la sélection du périphérique :
    • si je prends le RAID, j’ai “Insert proper boot device”, le RAID n’est pas reconnu en tant que disque de boot !
    • si je prends le 250 Go, je retrouve la sélection des 2 Vista installés, je prends le 1er (celui du RAID) et… je démarre bien sur le RAID !

Comment se fait-il que je sois obligé d’indiquer que je veux booter sur le 250Go pour avoir accès à la sélection de l’OS, et prendre celui du RAID ???

Pourquoi le RAID n’est pas reconnu tout de suite et boote normalement comme un disque classique ???

Merci d’avance de votre aide, c’est assez urgent !!!

Si je règle en sorte que le RAID soit en premier, j’ai direct le message “Insert proper boot device”…

Il n’y a qu’en bootant sur le disque Hitachi que j’accède au choix de l’OS, dont celui qui figure sur le RAID, et qui arrive à ce moment là à se lancer…

Tu a du installer en premier vista sur le disque non RAID et tu a fait la seconde install de vista sur le RAID mais tu a gardé branché le disque non RAID. Comme c’est celui ci qui a le fichier de boot : boot.ini.
Tu a donc besoin de ce disque pour booter entre tes 2 installs de Vista puisque ton disque RAID ne doit pas avoir de fichier boot.ini

Et que se passe-t-il quand tu règles le BIOS sur RAID et que tu démarres normalement (sans appuyer sur F8) ?
Est-ce que tu as un menu avec tes 2 OS ?

Sinon, il n’y a pas de boot.ini avec Vista, il y a un fichier (binaire) BCD que l’on peut modifier avec bcdedit.exe (en ligne de commande) ou avec des outils freeware tels que VistaBootPro ou EasyBcd (mon préféré).

Que veux-tu faire ? Conserver les 2 disques dur avec les 2 OS ?