Forum Clubic

Associer une extension de fichier à une application !

Associer une extension de fichier à une application est une procédure simple qui vous permet de gagner un temps précieux. Vous pourrez en effet ouvrir automatiquement vos fichiers avec tel ou tel logiciel. C’est ce que Clubic vous explique ici. Notez que la procédure est réalisée sous Windows 7, mais fonctionne également sous Windows Vista.

+Étape 1: Accédez au menu Démarrer puis Panneau de Configuration et Programmes par défaut.

+Étape 2: Choisissez ensuite l’option Associer un type de fichier ou un protocole à un programme. Vous accédez alors à l’intégralité des extensions proposées par Windows et le programme d’ouverture associé. Certains programmes sont proposés par défaut. Si votre application est absente de la liste, il vous sera possible d’indiquer le chemin vers l’exécutable en question.

+Étape 3: Pour modifier ou ajouter un programme, double cliquez sur l’extension de votre choix et modifier le programme par défaut dans le menu proposé.

A partir de maintenant, vos fichiers seront ouverts automatiquement avec vos logiciels favoris !

J’ai par erreur associer mon extension “.qs” avec le bloc note sans décocher de “toujours utiliser le programme sélectionné avec ce type de fichier”!

Maintenant mon fichier s’ouvre avec le bloc note, mais comment faire marche arrière sous windows 7 ?

Le truc du “options de fichier” ne marche pas comme avec XP du coup, je ne sais plus quoi faire.

Bonjour,
J’ai téléchargé un logiciel de géométrie dynamique : Géoplangéospace.
Mon ordinateur sous Windows 7 refuse d’associer les fichiers géoplangéospace (.g2w et .g3w) au programme : j’ai suivi vos instructions et quand je fais parcourir et que je sélectionne le programme, celui n’est pas sélectionné par l’ordinateur.:frowning: Que dois je faire ?
Merci pour votre aide.

Bonjour,
OK pour la méthode “Associer une extension de fichier à une application” marche bien sauf pour fichier avec extension .pdf (Adobe Reader) Elle est bloquée sur Microsoft Outlook. Je ne peux pas aussi cocher la case “Toujours utiliser le programme sélectionné pour ouvrir ce type de fichier” dans (clic droit sur fichier .pdf ==> ouvrir avec ==> choisir le programme par défaut).
Mes fichier .pdf ne sont pas corrompus car je les ouvre sans problème avec Adobe Reader 8.1.

  • W7 édition familiale Premium service Pack 1
  • Intel I5-3570K
  • 64bits
  • Adobe Reader 8.1.0
  • Office Pro Plus 2010
  • Outloock 14.0.7106.5003 (32bit)
    Merci pour votre aide. je surf sur internet pour trouver une solution depuis 8 jours en vain
    Cordialement.

Bonjour tout le monde!!!
J’ai un problème pour associer des extensions à un programme.
Par exemple, quand je fais toute la démarche décrite ci-dessus pour associer les .txt à notepad++, et bien rien ne se passe. Et les modifications ne sont pas prises en compte. C’est-à-dire que lorsque je vais ouvrir un fichier .txt en double cliquant dessus, il va me l’ouvrir avec le bloc note par défaut.

Je comprends pas d’où vient le problème. J’ai déjà essayé avec d’autres extensions (.java pour l’ouvrir par défaut avec notepad++)
Alors je me suis dit que le problème peut venir de notepad++, alors je l’ai désinstallé et réinstaller mais aucun changement.

SVP aidez-moi.

Merci

PS : je suis sous Win 8 (je n’ai pas update à la version 8.1, vous croyez que le problème vient de là ?)

J’ai moi aussi cherché longtemps une solution à un problème similaire. Je décris exactement mon problème et vous expose la solution ensuite.

Après avoir installé SublimeText 2, je souhaite pouvoir faire un double clic et ouvrir tous les fichiers du type “.sublime-snippet”, “.sublime-settings”, “.sublime-keymap”, etc. Je fais donc un double clic, windows ne reconnait pas l’extension et me propose de sélectionner un logiciel pour ouvrir, bien sûr, comme attendu, il ne se trouve pas la liste proposée, je fais donc “Parcourir”, je vais chercher le fichier “sublime_text.exe”, ok… et là, alors que je suis toujours sur la fenêtre de sélection du programme où normalement il ne me resterait plus qu’à cocher la case “toujours ouvrir avec ce logiciel”… je constate que ma sélection est tout bonnement ignorée et qu’en réalité, c’est comme si je n’avais pas sélectionné le logiciel… Donc en gros, IMPOSSIBLE d’ajouter “Sublime_text.exe” comme programme par défaut…

Après de très nombreuses recherches, j’ai ENFIN trouvé la solution: voici le lien du post où j’ai trouvé la solution: http://www.developpez.net/forums/d996616/systemes/windows/windows-7/pb-liste-programmes-ouvrir/#post7759123

Au cas où ce lien viendrait à disparaitre, je recopie la solution:

Voilà. Je confirme cette solution, c’est immédiat et pas besoin de redémarrer l’ordinateur!