Forum Clubic

Apache -- localhost : ok mais pas le reste

Bonjour à tous,

J’ai un serveur web sous centos 5.3 sur lequel je fais tourner apache.
Aprés l’ajout de tout mes paquets utiles et l’installation de mes applis web ( GLPI et Openlaszlo ), j’y est accès que en local : localhost…
Avec un autre ordinateur dans le même reseau, je n’ai aucun accès : ipserveur…

Le reseau semble correct (Tous se ping)

Des idées ?
Edité le 21/06/2012 à 13:19

Dans les fichiers de conf d’Apache, la ligne autorisant les connexions autres que localhost est-elle décommentée ?

J’ai déjà eu un problème similaire à cause de cette foutue ligne :grrr:

Le “listen 80” dans mon .conf devrait suffire ?

Nan, le “listen 80” est là pour dire à Apache quel port il doit être à l’écoute.

C’est plus une ligne du genre “Allow/Deny from 127.0.0.1” si ma mémoire est bonne (ligne 480 234 sur WampServer)

<Directory “c: /wamp/www/”>
#
# Possible values for the Options directive are “None”, “All”,
# or any combination of:
# Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
#
# Note that “MultiViews” must be named explicitly — “Options All”
# doesn’t give it to you.
#
# The Options directive is both complicated and important. Please see
# httpd.apache.org…
# for more information.
#
Options Indexes FollowSymLinks

#
# AllowOverride controls what directives may be placed in .htaccess files.
# It can be "All", "None", or any combination of the keywords:
#   Options FileInfo AuthConfig Limit
#
AllowOverride all

#
# Controls who can get stuff from this server.
#

onlineoffline tag - don’t remove

Order Deny,Allow
[b][s]Deny[/s] Allow[/b] from all
Allow from 127.0.0.1
Edité le 20/06/2012 à 15:28

Ca fonctionne ?

Hum … Non, la commande était déjà en allow.

Sinon, j’ai pus me renseigner un peu, et sur une configuration par default, Apache ne peux gérer que un site web non ?
Alors que dans mon cas, je doit en avoir minimum deux.
Je viens de télécharger webmin pour simplifier la configuration, si le soucis viens du “multi-site”.
J’avais pensé à une régle de parefeu sur linux qui bloquerait les accès en port 80, je vais aller verifier.

Bon, j’ai verifié mon parefeu, et le problème ne vient pas de là …

J’ai un total de 3 “sites” à héberger:

- Le premier qui ne contient qu'une page html pour l'accueil avec les liens vers les autres. L'index.html est stocké dans /var/www/html
- Le second ( glpi ) stocké dans /var/www/html/glpi avec pour index : index.php
- Le troisième ( Appli openlaszlo ) stocké dans /var/www/html/test avec pour index : index.html

Une fois webmin installé, Je créer une première hôte virtuel pour mon 1er site avec comme nom de serveur index.mondomaine". Pas de problème pour l’accès en local.
Mais quand je créer une seconde hôte virtuel pour mon 2ième site avec comme nom de serveur “glpi.mondomaine”, je ne peux y accéder alors que mon DNS semble correctement configuré …
Des idées ?

Problème : resolus
Solution : pathétique … :
J’ai oublié l’attribut -R dans mon chmod … :nexath

Merci de ta contribution ! :slight_smile:
Edité le 21/06/2012 à 11:16

Mais de rien.

Pense à mettre [Résolu] dans le titre de ton sujet :wink: