Forum Clubic

[ALSA] Chipset NForce2 et le son

Salut a tous !

J’ai installer FC3 et Ubuntu et a chaque fois j’ai le meme probleme, a savoir, je n’ai pas de dmix qui marche et donc pas de multiplexage:(.

Sous FC3 j’ai quand meme le 5.1 mais sous ubuntu je ni arrive pas.
J’install pourtant les drivers nvidia (NForce***.sh).

Alors j’aimerais savoir toute distrib confondu, si vous avez reussi a avoir du multiplexage avec une carte mere a base de nforce2 et si oui, utiliser vous nvsound ou snd_intel8x0

COrdialement

snd_intel8x0 et http://desintegr.free.fr/index.php?page=linux/astuces#asound

Pour info tu as quel distrib ?
A tu des enceintes 5.1 ?

MErci en tout cas pour ce 1er element de reponse !

Gentoo en 2.1

Mais mon astuce fonctionne pour toutes les distros normalement.

Si tu est sous gnome tu as mis koi dans selecteur multimédia?
Alsa et en dessous OSs ?

Syndicat> avec le fichier asound.conf de desintegr (et le driver intel8x0), le multiplexage marche impec.
Par contre le 5.1 ne marche pas.

C’etait bien ce dont j’avais peur :frowning:
J’ai pas eu le temps de tester puisque je reinstall tout mon pc et que je laisse ce probleme delicat a la fin [:matleflou]

asbel> ta le 5.1 ? oui exact ESD pour le Sink par contre OSS pour la source par default

Ben j’ai des enceintes 5.1, oui. Alors si j’active le duplicate front, ça marche (même chose sur les frontaux et sur les surround), mais si j’essaie de jouer un dvd en DD5.1, xine me dit que le périph est occupé. J’ai essayé toutes les options de xine et d’alsamixer, mais rien à faire. Pas encore pris le temps de fouiller sur le net pour trouver une solution

Bah moi pareil quand javais FC3 :frowning:
Mais les drivers nvidia c’est vraiment le coter obscur?

Avec les drivers nvidia, tout marche (multiplexage et 5.1), mais il y a un son bizarre de temps en temps (genre craquement ou explosion), c’est pour ça que je suis repassé à intel8x0.

Sinon tu vas sur le site d’ALSA, il y a plein plein de fichiers de configuration.

Multiplexage + 5.1 doit bien se trouver.

Ok merci j’ver voir tout ca sur le site

J’ai installer les drivers nvidia en désespoir de cause, j’avais pas de 5.1, et je parle meme pas de multiplexage :frowning:
Alors apres l’install, xmms me dit que le périph est occuper, mais oh magie Amarok marche alors je regarde dans les output plugin et jvois EDSSink.
J’ai en quelque sorte le multiplexage car j’ai les sons systemes ! mais pas xmms qui tourne sur alsa si je comprend bien ?
J’ai aussi un prob, au démarage a un moment ya pleuin de bipbipbbip asser agréssif pour mes oreilles :stuck_out_tongue:
avec le message, badnumber (device ?) ché pas koi a propos de la carte son.

en cadeau:


/home/vince # cat /etc/modules.conf
        # ALSA portion
        alias char-major-116 snd
        #alias snd-card-0 snd-intel8x0
        alias sound-card-0 nvsound
        # module options should go here

        # OSS/Free portion
        alias char-major-14 soundcore
        alias sound-slot-0 snd-card-0

        # card #1
        alias sound-service-0-0 snd-mixer-oss
        alias sound-service-0-1 snd-seq-oss
        alias sound-service-0-3 snd-pcm-oss
        alias sound-service-0-8 snd-seq-oss
        alias sound-service-0-12 snd-pcm-oss

install nvsound /sbin/modprobe --ignore-install nvsound ; sleep 1; /usr/bin/nvmix-reg -f /etc/nvmixrc -L >/dev/null 2>&1 || :
remove nvsound { /usr/bin/nvmix-reg -f /etc/nvmixrc -S >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove nvsound

root@amd2800:/home/vince # cat /etc/asound.conf
pcm.intel8x0 {
        type hw
        card 0
}

ctl.intel8x0 {
        type hw
        card 0
}

pcm.nforce-hw {
        type hw
        card 0
}

pcm.!default {
        type plug
        slave.pcm "nforce"
}

pcm.nforce {
        type dmix
        ipc_key 1234
        slave {
                pcm "hw:0,0"
                period_time 0
                period_size 1024
                buffer_size 4096
                rate 48000
        }
}

ctl.nforce-hw {
        type hw
        card 0
}


un petit apt-get install xmms-arts devrait régler ce problème :wink:
Si tu utilises nvsound, désactive alsa, ça évitera la série de bips. (update-rc.d -f alsa remove)

Ca y’est tout marche, le 5.1 et le multiplexage (video sous vl, son sous xmms et bip du terminal ) :bounce:
T’est une bombe asbel :love:
PAr contre comment je fait pour que le nvmixer ce rappel des reglage apres reboot? a chaque fois je dois mettre 5.1 dans les settings?

Edit: pour que xmms marche j’ai mis eSound comme plugin de sorti

Ah oui, mince, j’ai tellement l’habitude d’arts, je n’avais pas vu que tu utilisais ESD.
Pour que les paramètres s’enregistrent automatiquement, il y a une procédure détaillée dans le README du Nforce, je ne l’ai pas sous la main mais chez moi ça marchait bien.

Pour le probleme du nvmixer, regarde dans /usr/share/doc/nforce/ReleasesNotes.html, il y a deux lignes a rajouter dans ton modules.conf. Moi sous Ubuntu même avec ces lignes, il ne retenait jamais la config parce qu’il ne les executais pas. Donc je l’ai tapé une fois à la main et c’etait bon. Je crois que c’est un truc du genre:
nvmixreg -f /etc/nvmixrc -S pour sauvegarder et -L pour charger. Donc tu lance le nvmixer, tu fais tes reglages et ensuites tu tapes ca.
Si je suis pas clair, dit le :smiley:

[EDIT] Pour xmms, OSS ne marche pas ?

OUAsi j’lai vu mais le probleme c’est qu’il parle pas d’ubuntu, c ca le prob :frowning:
et quand j’ai chercher sur google chui tomber sur un type comme moi qui savait pas vu que il etait ni sous suse ni sous FC3

Autre point epineux, j’ai installer 3ddesktop mais lorsque 3ddekd est lancé, y’a des saccades sur les videos (toutes les 3 sec) :frowning:
J’ai desinstallé powernowd, et ajouter
Option “RenderAccel” “true”
Option “VideoOverlay” “on”
dans mon xorg.conf mais rien y fait :x
Quelqu’un sur le net parlait denlever Load glx ce qui marche mais par contre j’ai plus de 3d :x

3ddesktop c’est pas le truc qui permet de changer de bureau avec une représentation en 3D ? Si c’est ca c’est marrant mais je l’ai viré au bout de 5 minutes :smiley:

Arrete Comment timpressionne ta copine (ou plutot celle que tu convoite :ane:), genre un jour y’a une fille chez moi:
Elle: “Le_syndicat, tu me laisse consulté hotmail stp”
et la un coup de Ctrl+Alt+S -> 3ddesk :smiley:
Moi: “Voila”
Elle: “Ouuuuuah c’est encore mieux que matrix prend moi la bouche grand geek” :whistle:

Lithium sans passe plus, d’apres un de ces anciens post (help me, je veux soulever [:matleflou] :ane:).

Maintenant que j’ai reussi (a part les settings qui se dereglent a chaque reboot) a mettre le support du 5.1 + multiplexage, esce que si j’install plus tard une debian (sarge surement) avec le meme reglage ca marchera ou pas obliger?