Forum Clubic

Aide excel

Bonjour,

J’ai 2 fichiers excel, l’un avec une colonne A (nommé catalogue) avec des références

L’autre avec une colonne A avec des références et une colonne C avec des prix (nommé Listing)

Est il possible de faire une “comparaison sur les colonnes A” et me rajouter le prix des colonnes C du fichier listing dans le 1er fichier catalogue sur la colonne G (par exemple)

En fait j’ai un catalogue avec des références et des produits + infos produits dans un fichier. Et j’aimerai y rajouter les prix qui eux sont sur des listings suivant les clients.

Merci d’avance

Voici une piste. Je n’ai pas excel mais LibreOffice, il faudra peut-être adapté, mais c’est très voisin.

Dans mon exemple, le fichier listing contient en colonne A et C :
Colonne A…Colonne C
1…100
2…200
3…100
4…300
10…400
11…100
50…200
54…500
12…500
18…100
25…300
56…400

le fichier Catalogue contient en colonne A :
Colonne A
1
2
3
4
10
11
50
54
12
18
25
56

Ces 2 fichiers sont sur un disque E

En G1 du fichier Catalogue :
=RECHERCHEV(A1;‘file:///E:/Listing.xls’#$Feuille1.$A$1:$C$12;3;0)

Puis répéter la formule sur les 12 lignes du fichier Catalogue en colonne G

Vois déjà ce que cela donne.

Je crois que sous excel, il faut mettre feuil1 à la place de feuille1.
Edité le 22/05/2012 à 10:20

En excel, ça va te donner quelque chose du genre
=RECHERCHEV(A1;‘E:[Listing.xls]Feuil1’!$A$1:$C$12;3;0)