Forum Clubic

Aide création macro

bonjour,
je recherche une macro qui me permettrait d’exécuter les données suivantes :

en 2001: j’ai X numéros
je désire afficher les coordonnées de ces divers numéros (référencées en 2000) sur une nouvelle feuille du classeur 2001

si quelqu’un peut m’aider…

feuille 2000:
A B C D
numéro nom prénom dpt
11762K dupont jean 73
05004P durand anne 44

feuille 2001:
A
numéro
11762K
05004P

résultat
sur la feuille 2 de 2001:
A B C D
numéro(2001) nom prénom dpt
… … … …

Pourquoi faire une macro ?
Tu as la fonction RECHERCHEV() qui est faite pour ca

bonjour gcc,
je sais bien qu’il y a recherchev
mais je n’arrive pas à la faire exécuter convenablement!
(d’habitude elle passe bien mais là, des fois ça passe et des fois j’ai des messages d’erreurs)

pour exemple :
sur la feuille 2 de 2001 (ça me donne):
A B …
numéro nom …
11762K dupont =recherchev((A2;[2000.xls]Feuil1!$A$1:$D$7;2) = ici ça fonctionne!
05004P #N/A =RECHERCHEV(A3;[2000.xls]Feuil1!$A$1:$D$7;2) = ici ça NE fonctionne PAS!

je viens de capter!
j’avais oublier de faire le tri pour que la formule s’exécute complètement (pour tous les cas!)