Forum Clubic

Agregation de lien

Bonjour,
pclinux1–(ethernet)–switch–(ethernet1)–switch–(ethernet)–pclinux2
pclinux3–| |–(ethernet2)–| |–pclinux4

l’ethernet 2 est en dessous du 1 et le pc 4 est en dessou du 2

voici la petite architecture test que j’ai.
J’ai deux switch AT-8000s que j’ai configurés en mode trunk.
Il y a trois vlan; vlan1 (natif), vlan2 ou sont pc1 et pc2 et vlan3 ou sont pc3 et pc4.
le problème est que quand j’envoi un fichier du pc1 au pc2 et du pc3 au pc4 en meme temp, ils passent toujours par le meme lien.
Moi j’aurai voulu que le premier transfert se fasse sur ethernet1 et le deuxième sur ethernet2.
Par contre si je coupe ethernet1, le transfert passe bien par ethernet2.
Pour mieux voir les résultats au niveau de la vitesse, j’ai configurés tous les ports à 10M.

Quelles commandes dois je tapper pour faire en sorte que le transfert se passe sur les deux liens.
Merci

je voudrai que le vlan 2 et 3 passe par les lien ethernet 1 et 2.
Mais qu’il y ait un équilibrage de trafic entre ces deux lien.
moi j’ai fait ca.

console# conf
console(config)# vlan database
console(config-vlan)# vlan 2,3
console(config-vlan)# exit
console(config)# interface vlan 2
console(config-if)# name Amin
console(config-if)# exit
console(config)# interface vlan 3
console(config-if)# name pedago
console(config-if)# exit
console(conf)# interface range ethernet e(1-12)
console(conf-if)# switchport access vlan 2
console(conf-if)# no negotiation
console(conf-if)#speed 10
console(conf-if)# exit
console(conf)# interface range ethernet e(13-22)
console(conf-if)# switchport access vlan 3
console(conf-if)# no negotiation
console(conf-if)#speed 10
console(conf-if)# exit
console(conf)# interface range ethernet e(23-24)
console(conf-if)#channel-group 1 mode auto
console(conf-if)# exit
console(conf)# interface port-channel 1
console(conf-if)#switchport mode trunk
console(conf-if)#switchport trunk allowed vlan add 2,3
console(conf-if)# no negotiation
console(conf-if)#speed 10
console(conf-if)# exit

il me semble que chez Cisco c’est nommé EtherChannel


Ha, c'est des commut' Allied, je n'avait pas fait attention...

Ca doit etre LACP … ou Link agregation …

Salut,

je ne sais pas la ligne de commande, en revanche il faut regarder si tu trouves le loadbalancing, cela permet de répartir la charge… c’est ce que tu cherches a faire. Car l’aggrégation c’est aussi pour la performance
Edité le 23/05/2008 à 16:25