Forum Clubic

Afficher le contenu d'un cookie ou autre ?

Bonjour, j’utilise ce script pour pouvoir interchanger mes designs a volonter :

   <link rel="stylesheet" type="text/css" media="screen" title="Style de l'utilisateur" href="<?php echo (isset($_COOKIE['feuilleStyle'])) ? $_COOKIE['feuilleStyle'] : 'jeoffrey54' ; ?>.css" />

Seulement, j’aimerais afficher le style sélectionné.

J’ai testé echo $_COOKIE[‘feuilleStyle’] mais ca n’a pas marché.

Comment faire ?

Bonne fin de journée :slight_smile:

Ce n’est pas un cookie, c’est une feuille de style, donc un fichier à part entière.
Pour le charger, il suffit de taper son adresse dans la barre d’adresse de ton navigateur
Ou alors, avec firefox et l’extension web developer, tu as une option du menu pour visualiser les CSS de ta feuille active.

Mais non, ce n’est pas du tout ca.

Le switcher de thème sélectionne le thème, et moi j’aimerais qu’il m’affiche le thème que j’ai sélectionné, car je possède 3 ficheirs css, et mon switcher de thèmes choisi le fichier css via un lien.

Donc moi j’aimerais afficher Vous avez choisi le thème “nom du theme.css”.

Voila.

Sinon porui affiche le css, pas de problème, j’ai déja Web Developper :wink:

J’ai un petit écran et je n’avais pas vu que ton texte dépassait la zone en grisé !!!
tu l’as mise où, ta ligne echo $_COOKIE[‘feuilleStyle’] ?
il faut que tu fasses l’essai avec quelque chose du style
echo "Ma feuille de style : " . $_COOKIE[‘feuilleStyle’]
pour voir si c’est un pb d’affichage ou un pb de récupération du cookie
Au pire, pour en avoir le coeur net, tu commences en ne metttant que cette ligne dans le body

Et tu peux toujours faire un var_dump de $_COOKIE pour voir tous les cookies définis.

:etonne2: :etonne2: :etonne2:

je viens d’essayer

<?php echo $_COOKIE['feuilleStyle']; ?>

et ca marche :expressionless:

J’avoue être surpris, ca marchait aps avant :expressionless:

Merci a tous en tout ca !

parce que tu n’avais peut être pas déclaré de cookie pour la feuille de style. Vérifies en vidant tes cookies et en relançant la page avec le echo, pour être sûr :wink:

Ouais, c’est tout à fait ca, j’ai formaté il y’ a 2 jours, et évidemment, je n’avais plus le cookie du design de mon site! Donc forcément il ne m’affichait rien :slight_smile: