Forum Clubic

Affichage automatique de 2 dates dans excel

Bonjour,

J’aimerai trouver la formule pour indiquer la chose suivante :

J’ai une date de départ et je veux qu’en fonction de cette date, excel m’indique automatiquement la date à laquelle aura lieu une action spécifique conditionnée comme suit :

  • L’action a lieu le 5 du mois si la date de départ est comprise entre le 21 et le 5 du mois.
  • L’action a lieu le 20 du mois si la date de départ est comprise entre le 6 et le 20 du mois.

Exemples :

  • si ma date de départ est le 12/09/2018, l’action aura lieu le 20/09/2018
  • si ma date de départ est le 23/09/2018, l’action aura lieu le 05/10/2018

J’ai commencé ma formule comme suit, mais j’obtiens un 5 ou un 20 dans la cellule et non une date. Date de départ = B4
=SI(ET(B4>5;B4<21);“20”;“5”).

Je ne suis pas très douée sur Excel donc si quelqu’un a la réponse, je suis preneuse !
Merci d’avance

Une première piste :
Je suis sous Libreoffice et pas excel, donc il y aura peut-être une petite adaptation…
B contient la date de départ.
En cellule C :
=SI(ET(JOUR(B1)>5;JOUR(B1)<21); CONCATENER(“20/”;MOIS(B1);"/";ANNEE(B1));CONCATENER(“05/”;MOIS(B1);"/";ANNEE(B1)))

Reste à solutionner le changement de mois.
Je cherche.

Je reviens.
Pour ne pas faire une fonction “usine à gaz” je passe par 2 fonctions :
En B1, j’ai la date de départ. exemple : 02/11/2018
En F1, j’ai un format date avec affichage du mois uniquement et la formule :
=SI(JOUR(B1)>=21;MOIS.DECALER(B1;1);B1)
Résultat : le mois en cours ou le mois suivant, (en fonction de la date de départ). par exemple : 11
En C1, j’ai le résultat :
=SI(ET(JOUR(B1)>5;JOUR(B1)<21); CONCATENER(“20/”;MOIS(F1);"/";ANNEE(B1));CONCATENER(“05/”;MOIS(F1);"/";ANNEE(B1)))
Par exemple : 05/11/2018

Bonjour,

Une autre approche :
www.cjoint.com…

Crdlmt

Bravo djidji, c’est nettement plus esthétique que ce que je proposais. :jap: