Forum Clubic

Affichage accents en console - sous Xubuntu

Iaorana à tou(te)s,

j’ai installé une belle xubuntu.
C’est fluide, rapide (que du bonheur quoi !).
cool.

Toutefois, lorsque je suis en mode console (je n’arrive pas à m’en passer),
j’ai mes textes qui s’affichent comme tels :

Comment faire pour que tout s’affiche niquel ?

EDIT : J’ai bien tenté de jouer avec locales mais que nenni
Edité le 16/11/2007 à 16:52

en mode console dans un VT ? dans une console virtuelle sous XFCe ??

moi j’ai maintenant toutes mes consoles en utf-8 et j’ai plus de problèmes. jette un oeil de ce coté.

En l’occurence, j’étais sous putty en ssh

je vais regarder du coté de utf8 seulement, car je crois me souvenir d’avoir mis utf8@euro

arghh ! le dpkg-reconfigure locales ne me permet pas de changer le mode.

Comment faire sous Xubuntu ?

oublie, windows ne sait pas gêrer la localisation, et perso je ne changerai pas mon utf-8 pour windows, ça apporte des merdes pas possibledès que tu veux échanger des fichiers avec des accents à des pas français (sur le net par exemple)

ok, mais comment vérifier en quelle locale je suis ?

EDIT : est-ce la commande echo $LANG ?


$> locale
LANG=fr_FR.UTF-8
LC_CTYPE="fr_FR.UTF-8"
LC_NUMERIC="fr_FR.UTF-8"
LC_TIME="fr_FR.UTF-8"
LC_COLLATE="fr_FR.UTF-8"
LC_MONETARY="fr_FR.UTF-8"
LC_MESSAGES="fr_FR.UTF-8"
LC_PAPER="fr_FR.UTF-8"
LC_NAME="fr_FR.UTF-8"
LC_ADDRESS="fr_FR.UTF-8"
LC_TELEPHONE="fr_FR.UTF-8"
LC_MEASUREMENT="fr_FR.UTF-8"
LC_IDENTIFICATION="fr_FR.UTF-8"
LC_ALL=

cool, merci.

je suis également en fr_FR.UTF-8

Cela vient donc de l’affichage de putty.

rhaaa ces O/S micro$oftiens…

entre-temps, j’ai découvert que putty permettait de choisir le type de locale pour l’affichage.

Je suis passé sur la xubuntu 7.10 qui semble être gutsy (d’ailleurs j’aimerai bien savoir comment on fait pour connaître la version de xubuntu quand on est DANS le système).

Toutefois, elle ne semble pas plus réactive et/ou efficace si on veut transformer les locales utf8 par défaut en iso8859-15 euro par exemple.

c’est ce que j’allais dire : c’est au niveau de putty qu’il faut configurer ca… ni sur windows ni sur ton serveur… heureusement…

Sur le serveur (xubuntu en l’occurrence), les locales sont sur utf8.

Si tu n’es pas d’accord avec ce choix, c’est tout de même chaud de le changer (tout du moins en attendant qu’UTF8 deviennent le standard)

Je reviens sur ce sujet car j’ai fait des découvertes depuis.

J’ai joué avec la vmware player[/url] et surtout les machines virtuelles proposées par [url=http://www.vmware.com/appliances/]les gens.

Beaucoup sont en VO.

J’ai remarqué que sous xubuntu, il fallait installer le paquet console-data pour charger le clavier azerty

sudo apt-get install console-data && loadkeys fr

Toutefois, au démarrage suivant, loadkeys chargeait à nouveau la VO.

Pour XFCE, j’ai modifié à la main la ligne 23 où apparaît [quote=""]
Option “XkbLayout” “us”
[/quote]
pour remplacer par “fr” dans
/etc/X11/xorg.conf

Dans ma xubuntu à moi, je suis en vf en console et dans XFCE et le paquet console-data n’est pas installé.
J’en déduis qu’il y a d’autres moyens pour parvenir aux mêmes résultats.

C’est souvent le cas dans l’informatique et c’est encore plus vrai sous linux.