Forum Clubic

Activité disque dur permanente

Bonjour,

Je possède depuis une semaine un pc tournant sous Windows 7 Familial Premium 64bits.
La machine est équipé d un processeur Intel i7 860 et de 6 Go de ram.

Depuis son installation je constate une activité permanente du disque dur (led qui clignote toutes les deux secondes) alors même qu aucune application n est ouverte ni même la session utilisateur.
Le phénomène persiste alors que l indexation des disques dur est désactivée, même chose pour le service Windows search et Superfech ou encore l anti-virus.

Je ne vois pas ce qui peut provoquer cette activité.

Je possède une autre machine sous Vista sur laquelle la led du disque dur clignote uniquement lorsque ce dernier est sollicité.

Est-ce un comportement normal de Windows 7 ?
Il y a-t-il un service spécifique à configurer ou à désactiver?

Merci pour votre aide.
Edité le 10/08/2010 à 12:25

Bonjour .

Ce n’est pas évident de déterminer le processus qui est à l’origine de la sollicitation

du disque , dans un premier temps faire ceci :

Cliquer sur Démarrer \ Exécuter , taper msconfig

Ouvrir l’onglet Démarrage , décocher toutes les cases .

Ouvrir l’onglet Services , cocher la case Masquer tous les services Microsoft ,

Cliquer sur Désactiver tout , Appliquer \ Ok

Relancer le Pc , puis constater .
Edité le 10/08/2010 à 12:35

Bah si …

Moniteur de performance => onglet disque dur :neutre:
(accessible depuis l’onglet “performance” du gestionnaire de tache)
Edité le 10/08/2010 à 15:22

Oui , d’accord , c’est une première approche , mais il peut y avoir plusieurs processus .

Dans un premier temps , procéder par élimination .

Après on verra avec Procexp .
Edité le 10/08/2010 à 15:38

Comme suggéré, j’ai désactivé l’ensemble des programmes se chargeant au démarrage ainsi que tous les services (hors services Windows).
Après reboot de la machine, le disque dur continu à montrer une activité sans aucune sollicitation.

Pour voir s’il y a une activité anormale

Télécharger Process Explorer (de Sysinternals) :

www.clubic.com…

Le lancer , puis faire un clic droit sur ( hormis System Ystem Idle Prorcess) .

le(s) processus qui a (ont) le plus d’occupation en pourcentage , cliquer sur Properties , puis sur les onglets Services

et Image ,

on trouve les applications parentes du processus. Noter le(s) nom(s) du (des) services .

Ouvrir le registre , déployer la branche

[b]HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services[/b]

Repérer le(s) noms du (des) service(s) , regarder sur le volet de doite les informations concernant celui-ci (ou ceux-ci).

DisplayName et ImagePath .

Si tu te contente de cibler les processus qui ont le plus de pourcentage de temps CPU ça ne sert à rien :neutre:

Je peux facilement te montrer via le monteur de ressources que les processus qui font le plus d’accès disque ne sont pas ceux qui ont le temps CPU le plus élevé… loin de là !

Avec process Explorer il faut afficher les colonnes I/O pour éventuellement voir les processus qui font le plus de lecture/écriture. Mais c’est bien plus simple de les isoler via le moniteur de ressource et éventuellement inspecter le service en question avec process Explorer une fois qu’on a trouvé celui qui est en cause.

Maintenant je dirais que l’on a peut-etre là plutôt un faux problème.
Il ne faut pas être parano juste parce que la LED HDD du PC clignote régulièrement, ça ne veut pas forcément dire qu’on a un service/processus qui passe son temps à lire/écrire sur le disque. Ça n’est pas forcement quelque chose contre lequel il faut lutter :neutre:
Chez moi aussi la led clignote et je n’en fait pas une histoire… et mon PC fonctionne tres bien ainsi sans que j’ai à m’arracher les cheveux sur un quelconque problème qui n’en n’est pas un :wink:

Réponse à le-poilu , je suis sous Windows 7 32 bits , et quand aucune application

n’est lancée , la led d’'occupation du disque rest inerte tant qu’aucune n’est lancée ,

ou alors je dois être un extra terrestre .

Il suffit de faire un petite recherche sur google pour constater que le problème est un faux problème.

Des tas de gens constatent ce clignotemen sans jamais pouvoir déterminer d’autre symptôme qu’un clignotement de led (pas de processus tournant faisant des activités disque, tous les services désactivés, pas d’applications en tache de fond, etc)

L’histoire peut très bien venir d’un pilote de contrôleur disque, ou je ne sais quoi :neutre: de toute façon ça n’a aucune incidence sur le PC ou sur son usage (sauf si vraiment on constate qu’il y a effectivement un processus qui déconne à plein tube… ce qui est rarement le cas)

D’ailleurs un rapide coup d’oeil à mon moniteur de ressource pour constater (au même titre que d’autres si on cherche un peu) qu’un des processus qui génère régulièrement des accès disque quand aucune autre appli ne tourne ni aucun autre service c’est le journal de volume NTFS. C’est à dire une fonction essentielle au fonctionnement d’un volume formaté en NTFS et sur lequel le système s’appui pour pas mal d’opération (telles que l’usage de la corbeille et j’en passe)

Cela n’empêche pas la mise en veille du disque dur si la gestion d’alimentation est configurée comme telle. Cela n’a aucune incidence sur les perf du PC (au contraire ça aurait même tendance contribuer à les améliorer) et cela ne représente même pas quelques ko/s dans les faits.

Donc comme dit: à moins que l’on arrive à isoler un processus ou une application qui fait vraiment tourner le disque dur de manière anormale (ce qui se vérifie en un coup d’oeil dans le moniteur de ressources), il n’y a pas de quoi se prendre la tête sur ce point!
Edité le 10/08/2010 à 23:48

J’ai vérifié les processus qui sollicitent le disque dur en dehors de toute activité.
Il y en a deux ou trois qui reviennent (tous des processus système) de manière régulière et qui représentent à peine 1% de l’activité.
D’autre part il y a effectivement le processus du journal de volume NTFS qui intervient également.

Ce qui me fait penser que zaboukou tout comme Le_poilu avez tous les deux raison.

En effet, comme signalé par zaboukou qui précise que sur son Windows 7 la led de son disque dur n’est sollicitée que lorsqu’une application est lancée, je constate moi-même la même chose sur une autre configuration avec Windows Vista.
C’est ce qui m’a par ailleurs fait poser la question par rapport à ma configuration sous Windows 7.

D’un autre côté Le_poilu mentionne éventuellement le pilote du contrôleur disque et notamment le processus du journal de volume NTFS ce que je peux effectivement confirmer.
Je confirme également qu’il n’y a aucun impact sur les performances de la machine.

Après loin de moi l’envie de me « prendre la tête » avec cela et encore moins d’être paranoïaque.
Le but de la question était simplement de savoir s’il s’agissait d’un comportement « normal » ou pas du système.

Dans tous les cas je vous remercie tous les deux d’avoir pris le temps pour me répondre.