Forum Clubic

Accés refusé lecteur jazz [Résolu]

Bonjour les linuxiens,

fatigué des frasques de windows, j’ai decidé de passer a GNU/Linux (Debian/sarge). Tout va pour le mieux sauf mon lecteur jazz. Voila comment je m’y suis pris :

J’ai rajouté la ligne suivante dans mon fstab :

/dev/sda4 /media/jazz0 auto rw,user,noauto 0 0

j’ai ensuite créé un dossier jazz dans :

/media http://img116.exs.cx/img116/934/z0tdntknw.gif

Je me loggue en root (bastille inside) pour monter mon lecteur, celui apparait monté dans konqueror mais quand je veux y entrer :

accés refusé

Si je lance konqueror en root je peux acceder a mon lecteur, j’ai alors pensé a un problème de droits, donc :

addgrp jazz

chgrp jazz /dev/sda*

adduser MarioBrosse jazz

Ben ça a rien changéhttp://img.photobucket.com/albums/v58/Honushi/smilies/neutral.gif

Voila ou j’en suis, si quelqu’un a une ébauche de réponse, je suis preneur :jap:

mais normalement, si tu mets user, les utilisateurs autres que le root sont autorisés à monter le lecteur, mais le “lecteur” appartient à l’utilisateur qui le monte… donc logiquement, si tu le monte en root, il appartiendra à root, et donc pas accessible aux autres… :fou: t’as essayé de le monter en tant qu’utilisateur normal ?

user Autoriser les utilisateurs ordinaires (non root) à monter
le système de fichiers. Ceci entraîne l’utilisation des
options noexec, nosuid, et nodev (à moins qu’elles ne
soient explicitement surchargées, comme dans une ligne
d’option user,exec,dev,suid).
:wink:

Dans les options, rajoute umask=0. (et mets users à la place de user, c’est plus pratique pour tout ce qui est disques amovibles)

J’ai l’erreur suivante:

wrong fs type, bad option, bad superblock on /dev/sda4,
or too many mounted file systems

Si je ne fais que changer user en users, je n’ai pas d’erreur mais ca change rien !

Bastille a enlevé les droits sur la commande mount mais pas sur les fichiers, ca marche tres bien avec mon lecteur de cdrom… (enfin je crois que c’est un truc comme ça, c’est pas encore tres clair ces histoires de droits, groupes, suid, guid…)

J’ai fait ls -la dans media :

drwxr-xr-x 6 root root 216 2005-01-26 19:15 .
drwxr-xr-x 21 root root 592 2005-01-10 08:38 …
lrwxrwxrwx 1 root root 6 2005-01-03 20:29 cdrom -> cdrom0
drwxr-xr-x 2 root root 48 2005-01-03 20:29 cdrom0
drwxr-xr-x 2 root root 48 2005-01-03 20:29 cdrom1
lrwxrwxrwx 1 root root 7 2005-01-03 20:29 floppy -> floppy0
drwxr-xr-x 2 root root 48 2005-01-03 20:29 floppy0
lrwxrwxrwx 1 root root 5 2005-01-26 19:15 jazz -> jazz0
drwxr–r-- 4 root root 16384 1970-01-01 01:00 jazz0

y a pas comme un petit probleme sur la ligne du bas?

J’ai essayé :

chmod a+xw /media/jazz0

Rien… Toujours pareil… Comment je fais pour changer les droits sur ce dossier ???http://www.foroedonkey.com/vb/images/smilies/pensando.gif

normalement c’est avec uid,gid et umask pour un montage, pas avec chmod :smiley: :
-uid=500 te définit le contenu monté comme appartenant à l’utilisateur ayant comme numéro 500
-gid=500 te définit le contenu monté comme appartenant au groupe ayant comme numéro 500
-umask=xxx (x=un chiffre) définit les permissions lecture/écriture/exécution à la manière de chmod (mais les bits sont inversés je crois ;))

tu devrais pouvoir compléter ton fstab avec ça :wink:

sinon va voir sur léa-linux => http://lea-linux.org/admin/fstab.html

[quote=“MarioBrosse”]

Les droits du répertoire sont modifiés suivant les options de montage.
Le jazz zst formaté avec quel File systèm? fat, ext3,…

On est d’accord que ça doit donner ça :
[fixed]/dev/sda4 /media/jazz0 auto rw,umask=0,user,noauto 0 0[/fixed]
Ca marche avec mon Zip, y a pas de raison…

Pour le users à la place de user, ça permet juste à tout le monde de le démonter.

[fixed]
/dev/sda4 /media/jazz0 auto rw,umask=0,user,noauto 0 0[/fixed]

+1 et à la rigueur, le umask n’est pas utile.
Ca tourne comme ça avec mes clefs USB et mon disque dur externe.

Merci les gars de m’aider ! :jap:

Ben je cherches pas a le monter, je cherche lui donner les droits.

chmod - Modifier les autorisations d’accès à un fichier. <-- j’ai lu ça dans le man… Je m’a planté?

D’ailleurs, j’en suis la :

drwxr-xr-x 6 root root 216 2005-01-26 19:15 .
drwxr-xr-x 21 root root 592 2005-01-10 08:38 …
lrwxrwxrwx 1 root root 6 2005-01-03 20:29 cdrom -> cdrom0
drwxr-xr-x 2 root root 48 2005-01-03 20:29 cdrom0
drwxr-xr-x 2 root root 48 2005-01-03 20:29 cdrom1
lrwxrwxrwx 1 root root 7 2005-01-03 20:29 floppy -> floppy0
drwxr-xr-x 2 root root 48 2005-01-03 20:29 floppy0
lrwxrwxrwx 1 root root 5 2005-01-26 19:15 jazz -> jazz0
drwxr-xr-x 2 root root 72 2005-01-26 19:14 jazz0

Mais ça marche toujours pas ! http://img133.exs.cx/img133/6927/explotar2jr.gif

J’ai bon ? En tous cas comme ça j’ai le message d’erreur !

http://users.pandora.be/eforum/emoticons4u/happy/1074.gif
fat… Comment je fais pour donner les droits a mon user sur un systeme de fichier???

[fixed]/dev/sda4 /media/jazz0 auto rw,umask0,user,noauto 0 0[/fixed]
manque le = entre umask et 0 :wink:
Mais normalement, même sans le umask=0, les utilisateurs devraient pouvoir le monter.

A moins que…
Ne monte pas le lecteur (ou démonte-le s’il est déjà monté), et vérifie les droits sur le répertoire /media/jazz0

asbel http://img103.exs.cx/img103/8760/friends3.gif

Maintenant ça fonctionne !

Merci a tous !

@+