Forum Clubic

Colorer une cellule en fonction de sa valeur

Bonjour,

J’ai une formule du style :


=SI(E4=20;"Félicitations";SI(E4>18;"Excellent";SI(E4>16;"Très Bien";SI(E4>14;"Bien";SI(E4>12;"Assez Bien";SI(E4>10;"Passable";"C'est quoi ça ?!""))))))

Et j’aimerais pouvoir colorer chaque valeur si vrai et valuer si faux en une couleur différente

Ps : j’utilise OpenOfice

Cordialement, Lebravex

Je suppose que ça ne change pas trop sous OOo: tu as une “Mise en forme conditionnelle” sous Format.

Cela permet de colorier une cellule en fonction d’un test quelconque. Par contre, c’est assez bancale sur la recopie (genre tu copie colle le format, il ne met pas systématiquement à jour les formules)

Cette astuce fonctionne sauf qu’il n’y a que trois possibilité alors que moi j’en voudarais 7. Et puis le mise en forme conditionnel sous OO n’est pas terrible.
Si vous avez d’autres solutions n’hésitez pas.

Coordialement, Lebravex

Je vois mal comment tu peux faire, malheureusement.

A moins que tu n’y ailles avec une macro? (je n’ai pas testé, mais tu dois pouvoir faire bien plus que ce que tu ne peux avec une simple mise en forme conditonnelle)